Wednesday, January 13, 2010

Bicoloring



The Problem

In 1976 the ``Four Color Map Theorem" was proven with the assistance of a computer. This theorem states that every map can be colored using only four colors, in such a way that no region is colored using the same color as a neighbor region.


Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary connected graph can be bicolored.
That is, if one can assign colors (from a palette of two) to the nodes in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:


  • no node will have an edge to itself.
  • the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must assume that b is connected to a.
  • the graph will be strongly connected. That is, there will be at least one path from any node to any other node.


Input
 


The input consists of several test cases. Each test case starts with a line containing the number n (1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will follow, each containing two numbers that specify an edge between the two nodes that they represent. A node in the graph will be labeled using a numbera .

An input with n = 0 will mark the end of the input and is not to be processed.


Output
 


You have to decide whether the input graph can be bicolored or not, and print it as shown below.


Sample Input 


3
3
0 1
1 2
2 0
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
0

Sample Output


NOT BICOLORABLE.
BICOLORABLE.


//  Bicoloring.cpp : Defines the entry point for the console application.


//


 


#include "stdafx.h"


 


 


//  Bicoloring.cpp : Defines the entry point for the console application.

//

#include "stdafx.h"

int _tmain(int argc, _TCHAR* argv[])

{
    while(scanf("%d",&n))
 {
  first=1;
        if(n!=0)
        {
            tru=0;
            scanf("%d",&e);
   for(i=0;i<n;i++)
   {
    B[i]=3;
   }
   for(i=0;i<e;i++)
     
   {
    for(j=0;j<2;j++)
    {
     scanf("%d",&A[i][j]);
     if(first==1 && B[A[i][j]]==3)
     {
      B[A[i][j]]=1;
      first=2;
     }
     else if(B[A[i][j]]==3)
     {
      if(j>0 && B[A[i][j-1]]==1)
      {
       B[A[i][j]]=2;
      }
      else if(j>0 && B[A[i][j-1]]==2)
      {
       B[A[i][j]]=1;
      }
      else if(j==0 && B[A[i][j+1]]==1)
      {
       B[A[i][j]]=2;
      }
      else if(j==0 && B[A[i][j+1]]==2)
      {
       B[A[i][j]]=1;
      }
     }        
    }
   }  
   for(i=0;i<e;i++)
   {
    for(j=0;j<2;j++)
    {
     col[j]=B[A[i][j]];
    }
    if(col[0]==col[1])
    {
     tru=1;
     break;
    }
   }
   if(tru==1)
   {printf("Not bicolorable.\n");}
   else
   {printf("Bicolorable.\n");}
  }
  else
  {return 0;}
 }
 return 0;
}

Output

3
3
0 1
1 2
2 0
Not bicolorable.

9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
0 8
Bicolorable.



No comments:

Post a Comment